1987 duel fuel tanks electric issues

Discussion in '1973-1987' started by Captain J, Dec 20, 2017.

  1. Captain J

    Captain J Member

    Joined:
    Dec 20, 2017
    Messages:
    8
    Hi, new to this forum.:)
    My truck is 1987 GMC Sierra R3500, with 7.4L and TBI, duel fuel tanks.
    Just got it restored, but I can’t select fuel from both tanks, I don’t hear any clicking sound in the fuel selector valve, nor the sending units. Only when I turn the key to on, I can hear the driver side fuel pump. I checked the electric on the selector switch (no power), checked the electric to the fuel valve selector no power, so are the fuel sending units.
    I’ll be replace both sending units with new ones,
    But why no electric power?
    Any thoughts?:cool:
     
  2. Jessica

    Jessica Member

    Joined:
    Nov 3, 2018
    Messages:
    1
    I have a 1987 Chevy C10 that has dual fuel tanks the driver side tank works fine, but after 2 fill ups in that tank the fuel was flowing out of the pass tank so we flipped the switch to use the pass. tank and you can hear the fuel pump but instead the truck dies. Please help!!!!
     
  3. vwnate1

    vwnate1 Member

    Joined:
    Jan 1, 2000
    Messages:
    11,141
    Location:
    AMERICA !
    Time to break out the test light, do not use a meter .

    Either no power to the switch or the changeover valve is gummed up / dirty contacts, like that .
     
  4. Ty Strawn

    Ty Strawn Member

    Joined:
    Apr 25, 2020
    Messages:
    3
    I have a 1987 V20 with fuel tank issues. The RH tank works fine I can start it cold on the LH tank and drive a little while then it acts like it’s out of fuel. Any help or ideas would be great.
     
  5. nerfherder78

    nerfherder78 Member

    Joined:
    Aug 15, 2003
    Messages:
    323
    Location:
    Fairfield, CA
    Sounds like the left tank isn't venting properly. When it does it try pulling the gas cap off and see if it releases any pressure. The tanks should vent through the charcoal canister, the lines run across the cab to the passanger side frame rail and T in with the right side lines before running up to the engine bay. Check for any kinks or a clogged line in there.
     
  6. Ty Strawn

    Ty Strawn Member

    Joined:
    Apr 25, 2020
    Messages:
    3
     
  7. Ty Strawn

    Ty Strawn Member

    Joined:
    Apr 25, 2020
    Messages:
    3
    Great thank you. I tried that. Left the cap off and drove a while. Spits and sputters will die if going slow. I’ll check the lines next. Appreciate the help.
     
  8. vwnate1

    vwnate1 Member

    Joined:
    Jan 1, 2000
    Messages:
    11,141
    Location:
    AMERICA !
    Your next test is simple ;

    Disconnect the problem tanks fuel line as close to the tank as possilbe and attach a bit of hose to it that reachs the ground and suck on it, you're looking for a strong gush of fuel the diameter of the inside of the hose, nothing less .

    This is called the 'siphon' and if fuel doesn't gush out you have a restricted /blocked pickup inside the tank, most tanks have a mesh or gauze on the pickup and over time (33 years) they collect debris and pack up .

    These are available here and there, resist the urge to simply remove it and Motor on....

    Let us know what you find .
     
  9. nerfherder78

    nerfherder78 Member

    Joined:
    Aug 15, 2003
    Messages:
    323
    Location:
    Fairfield, CA
    An '87 should have in tank fuel pumps rather than an engine mounted one. It could be that the left pump is going bad, and the few minutes its running good is whats in the line from the right tank. To test the pump, switch to the left tank. Locate the switcher valve on the right side frame rail under the cab and disconnect the supply line running to the engine, it'll be the larger of the two lines running through the switch. Have a pan ready to catch any fuel when you disconnect it. When you turn the key to run it should run the pump for a short time. If you have some 3/8" rubber fuel line you can hook that to the switch to control the flow. The tank mounted pumps also tend whine louder when they start wearing out.

    As Nate said it could also just be a blocked pickup or debris. When I bought my '98 K2500 a few years ago I found a leaf and some sludge on the "new" fuel filter. Dropped the tank and found the sock on the pickup was torn; I ended up cleaning or replacing the whole fuel system.
     
  10. vwnate1

    vwnate1 Member

    Joined:
    Jan 1, 2000
    Messages:
    11,141
    Location:
    AMERICA !
    WHOOPS ! .

    I forgot about the TBI fuel injection with it's electric fuel pumps .

    I guess I'm still stuck on the old carby dayze....
     

Share This Page